Jump to content

Welcome to FTB Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Desperate for lag help!


4 replies to this topic

#1
kwickbeam

kwickbeam

    Member

  • Members
  • PipPip
  • 12 posts
  • Modpack:Agrarian Skies

Ok before anyone asks, Yes I have tried increasing ram and changed the java options and added the advanced java script in the launcher. Nothing seems to work. And yes I spent hours searching and trying different fixes for lag that others have posted here and elsewhere. It starts from the word go so it isn't any pipe or duct or power or video issue with fire or water or moving parts.

My issue is every time I try to open anything with a GUI or inventory the game pauses or freezes from anywhere between 2 seconds to a full minute before it continues. Basically making interacting with almost anything non-vanilla, (or even vanilla like a chest), nearly unplayable. Open a chest (empty or full) and have to wait 10 to 20 sec for it to finish opening! open any machine to interact with it's GUI and again it freezes for as much as a minute.

I have spent hours looking for and trying different fixes for this but nothing seems to work. I'm Desperate now. I love the mod pack but it's pretty much more time waiting for something to open than actually playing time so basically unplayable!

HELP please?

Oh and yes I have thoroughly searched the support archive.



#2
timrem

timrem

    Advanced Member

  • Administrators
  • 1274 posts
  • Location:NJ, USA
  • Modpack:Direwolf20 1.7 Pack

Some diagnostic questions: Is this happening in a new world, or only in one you've been building in for a while? Singleplayer and/or on a server? Does the same lag occur when you stand on a pressure plate to open a door? Do you have a lava farm with Ex Nihilo crucibles? Have you tried other FTB 1.6 modpacks without issue?

 

Even though it isn't a crash, posting the console log may give some clue to the problem.



#3
kwickbeam

kwickbeam

    Member

  • Members
  • PipPip
  • 12 posts
  • Modpack:Agrarian Skies

This starts pretty much as soon as I start a new Agrarian Skies game. I haven't tried this on a server but in a single player game it starts from the very beginning. It only gets worse as I progress because the more advanced or farther along you get the more you have to open a GUI or inventory.

 

As for your questions... Single player, new world and it starts from the very beginning and just gets more and more annoying because the farther along you get the more GUIs or inventories you have to open. I haven't used any pressure plates so no idea. As for doors... no. Only really have 3 doors and never saw any issues with them, no freezing or pauses when opening them.

 

Other 1.6 packs I have tried are Monster, Tech World 2, Magic World 2 and Magic Farm 2 (all of them single and server). Also played FTBUltimate (1.4.7 single and server. No issues with any of them.

 

As far as things I have tried to fix this issues... here is a list.

 

Ok lets see.. first I tried adding dedicated ram. I have 16 gigs on my computer so I dedicated 10 full gigs just to Minecraft. Didn't change a thing.

Then I figured it might be a java problem so first I tried updating both 32 and 64bit java (I have both on the comp because I have a couple of older games that won't work on 64 bit). Didn't change anything either.

Then I saw a posting in the FTB support saying it might work to add in a JVM argument to the launcher http://support.feed-the-beast.com/questions/6987/insane-lags-on-agrarian-skies . This actually made things worse so I deleted it immediately but somehow lost all of the completed quests in the quest book.

I tried turning off NEI. Nothing changed.

I set all the video setting in the game to bare minimum. Again no change.

Same with audio settings. Nothing.

I even disabled InventoryTweaks because a friend who plays hates it and never seems to have lag. Still nothing.

I saw somewhere, not sure where now, that it could be my security settings on my virus protection with Java so I even added java as a specific exemption and that actually crashed the game and corrupted my latest save.

I turned OFF my virus protection to see if that would help and still no change.

 

Also just for shits and giggles I even updated my video and chipset drivers.



#4
kwickbeam

kwickbeam

    Member

  • Members
  • PipPip
  • 12 posts
  • Modpack:Agrarian Skies

My roommate tells me I should be a bit more specific. I haven't had actual video lag, this is an inventory and/or GUI issue. When I am not opening anything I have pretty much zero issues. It only gets annoying when I open something that has a GUI or inventory.



#5
kwickbeam

kwickbeam

    Member

  • Members
  • PipPip
  • 12 posts
  • Modpack:Agrarian Skies

Ok it looks like I fixed the problem. I must have installed Java 64bit incorrectly. I uninstalled all forms of Java and reinstalled it carefully following instructions and now the problem seems to be gone.

 

Thank you for the help.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users