Jump to content

Welcome to FTB Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Updating FTB Unleashed


6 replies to this topic

#1
Arakattack

Arakattack

    Newbie

  • Members
  • Pip
  • 1 posts
  • IGN:Arakattack
  • Modpack:FTB Unleashed

I just recently started running a small minecraft server for me and my girlfriend, and the couple times I've changed mod packs it's been to a whole different mod pack entirely. I've never updated versions of the same mod pack before.

 

So anyway, call me a newb if you must, but I downloaded the server files from feed-the-beast.com not from the launcher, so I got the old 1.1.3 version of FTB Unleashed, and I'm interested in updating to 1.1.6, so I decided to test it...

 

I copied the world files from my server into a singleplayer game, and tried to load it with a set of 1.1.6 binaries, and it threw a few error messages, but then proceeded to load, I couldn't really tell any differences... so I've got a few questions about it...

 

1) Is there any important changes to WorldGen between 1.1.3 and 1.1.6 that I would need to restart my world for...

 

2) If not, there was a couple block errors it mentioned, I remember two of them being from Tinker's Construct, that it said were no longer valid or something like that, I'm assuming that means some blocks were removed from TC and other mods? If I don't already have those blocks placed in the world or in my inventory, will it still throw those errors? 

 

3) With those errors, would I be able to continue playing, assuming there's no major changes to WorldGen, and that it won't make something break horribly somewhere down the line?

 

Essentially what I'm asking is, if I'm updating to 1.1.6 from 1.1.3 do I need to remake my world? I'd really prefer not to since my girlfriend and I have put a lot of work into our tower, and I've built into really late-stage Forestry, AE, Buildcraft, and mid-game IC2 stuff, and I'd really prefer not to make her and I both have to restart. I know some of these questions are kind of unanswerable without the exact errors that were produced, but I'm at work right now and don't have access to the world files to go trigger the errors.



#2
dgelessus

dgelessus

    Advanced Member

  • Administrators
  • 1424 posts
  • IGN:dgelessus
  • Modpack:FTB Tech World 2
Before doing anything, you should really back up your entire server folder, and if you modified your client's configs, back up the entire client config folder as well. That way you can quickly restore to the previous version in case something goes wrong.

There shouldn't be any issues with your worlds when updating, IIRC there was some internal block renaming, which makes FML think that blocks are missing. They are not really, it's just that FML's ID checker doesn't recognize them.
If you modified configs, you should copy the config folders of client and server elsewhere, update, and put them back. That shouldn't break anything, but if you have the time and want to be extra safe, update first and then go over and adjust the configs manually.

#3
felinoel

felinoel

    Steampunk Alchemist

  • Administrators
  • 3860 posts
  • Location:Somewhere, possibly?
  • IGN:felinoel
  • Modpack:FTB Mage Quest
So true you should always backup everything ALL THE TIME.
If at any point you feel you have backed too much stuff up, back up some more (I am only moderately exaggerating).

From what I can understand as he says there should never be a point when there is a problem from updating, from what I understand that is why the direwolf pack split off and became direwolf1.5, because they made some mod changes that anyone using the old pack would get issues from updating to so they made an entirely new pack instead.
Watch all of my different Let's Play series, Minecraft and more!
player.me/felinoel


We need to make default article pages! Discuss their designs here!

#4
ZL123

ZL123

    Me.

  • Administrators
  • 2079 posts
  • Location:Not somewhere where people say a fake location to try to be funny
  • IGN:ZL123
  • Modpack:Private Pack

QCraft was added in one of the later versions (I think either 1.1.5 or 1.1.6), which includes Quantum Ore, which drops Quantum Dust. Other than that, I don't think there are any World Generation changes.


-ZL123
Hope I helped!

YT: http://youtube.com/ZL234
Twitter: https://twitter.com/ZL234


#5
Kahless61

Kahless61

    Advanced Member

  • Contributor
  • PipPipPip
  • 101 posts
  • Modpack:FTB Ultimate

QCraft 1.0 was added in 1.1.5, and updated to 1.1 in 1.1.6 (fixes an item dupe bug). It will not affect terrain gen. New chunks will gen the ore, but since it doesn't affect terrain, you shouldn't see any chunk walls/borders.

1.1.7 was released a couple days ago with a bugfix that affect my server - IC2 and Advanced Solars had an incompatability that caused servers to not start, which they fixed in 1.1.7.

 

I've updated my server from 1.1.4 -> 1.1.5 -> 1.1.6 -> 1.1.7. Here's the general steps I follow:

1) Download the new server package. Unzip it. Prepare it. Re-do any config changes you made before. Re-add any additional mods you've added.

2) Shut down the server. Back up the minecraft folder. Back up the world folder (outside of the minecraft folder).

3) Copy over the new server package.

4) Start the server and watch the log to make sure it starts correctly.

5) Try to log in.

 

If steps 4/5 fail, copy the error logs, shut down the server, and restore the backup.

 

 

 

Update:

Just realized you're using 1.1.3. From 1.1.3 to 1.1.4 is a bit of a hurdle, since Tinker's Construct updated with a bunch of new stuff, including terrain gen (Slime Floating Islands - not a biome, just a structure/feature).

 

From experience updating in single player and servers, I know the following:

* Things should not break to the point of becoming unusable.

* You may find an item or block or set of items/blocks that simply vanish. These are items that had their ID changed or are no longer a part of the game. Not a big deal. In particular, I know that IC2 crop sticks had a tendency to lose their crops.

* You may find an item or entity with a bad texture. This is typically caused by an incorrect ID. Discard it. Things with bad/weird textures are usually glitchy and can corrupt your world. As long as you discard it and don't try to use/place it, you should be fine.

* You may find chunk boundaries - Sudden flat walls where terrain differs. Unlikely, but it can happen. It's just caused by new chunks generating differently from old ones. Nothing to be concerned about, just not the prettiest thing.



#6
LaserLight

LaserLight

    Newbie

  • Members
  • Pip
  • 1 posts
  • IGN:DevilLordLaser
  • Modpack:FTB Unleashed

Hello.

I'm having issues with updating our FTB Unleashed installation on Creeperhost.  I've inherited opsmanship of a CH server for a small group of friends, and for a long while now we've been running 1.1.2 because we're all more or less computer illiterate.  However, the bugs and creeping server decay have caught up to us and we're trying to figure out how to update things such that we can get our world to stop coughing up blood every now and then, starting with an update to 1.1.3 to test the waters and see if we can figure out how to do it.

Unfortunately, I seem to be very, very bad at server.  I followed the steps laid out in the post immediately above this, only to be unable to access the server due to mod version incompatibilities, and in my attempts to fix it I was eventually forced to restore from a back-up.  To summarize the issue:

1.) I downloaded the 1.1.3 modpack file and unzipped it.  As we'd never done anything to it beyond installing it, i.e. no config file changes, it was presumably prepared and ready.
2.) I shut down the server, backed it up around seventeen times because Creeperhost was being twitchy, and copied the world folder over to my own system.
3.) Here's the part where things seem to've gone south.  I copied over the unzipped folder, name of [modpacks^Unleashed^1_1_3^Unleashed-server] to the minecraft folder via dragging it from my desktop into the Minecraft folder area via Cyberduck.  Things seemed to go smoothly, until I restarted the server and we found mod version incompatibility issues.  Later, I discovered that the modpack folder had not integrated at all into the server data and was merely sitting there, with its own name, in a single spot in the minecraft folder right above the [mods] folder.  I later tried click-dragging the contents of the modpacks^*** folder over to the minecraft folder instead, rather than the original modpacks folder itself, but that managed to work so splendidly poorly I had to restore from backups.

It looked like all I needed to do was delete/refresh my 1.1.3 installation in the FTB launcher, which I've had to do before.  However, I did that and still managed to find incompatibilities - Applied Energistics was missing altogether, Tinker's Construct was behind a few revisions, and other, similar issues.  According to the error messages, it looked as if the server had those mods but I did not, local-side, which makes no sense to me whatsoever.

I'm very sorry for the secondhand idiocy and for taking up your time with such an idiotic request.  Will someone please be so kind as to let me know where I went wrong?  I'm getting somewhat desperate, new errors seem to be cropping up in this server every week.



#7
timrem

timrem

    Advanced Member

  • Administrators
  • 1274 posts
  • Location:NJ, USA
  • Modpack:Direwolf20 1.7 Pack

All you should have to do to update the modpack on CreeperHost is go to the "Minecraft>>Software Selection" tab, and chose to install "FTB Unleashed (v1.1.3)". If that doesn't do it, you're probably best off opening a support ticket through their control panel, since they offer support for this modpack, and they know their systems better than anybody here.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users