Jump to content

Welcome to FTB Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Major Chunk Errors/Maxed CPU


  • This topic is locked This topic is locked
3 replies to this topic

#1
HisServant77

HisServant77

    Newbie

  • Members
  • Pip
  • 2 posts
  • Modpack:MindCrack Pack

Hi Everyone

 

I really, really hope to get some help on this issue I'm having these past 4 or so days.

 

I'm using the MindCrack version of the modpack. Well, I've been on my world building and playing around for a good bit and have not had any problems at all for the entire duration. However, perhaps about 4-5 days ago, in my main area/base, I had a chunk error. Logged out, refreshed the game, did everything that normally works to fix the error, and nothing worked. It's a persistent chunk error.

 

Well, I didn't think too much about it, but was a bit worried something would be up so I first decided to build a wall around the chunk to hide and avoid running into it. Then I changed my mind and decided to just move to another area. I started experiencing major framerate problems, going into the single digits at times. Never had a problem before with this. I checked my CPU usage and found the culprit for the framerate: It was maxed out! Yet that makes no sense because on any normal play my CPU has never gone past 38% running FTB, watching a DVD movie, watching Youtube videos full screen on another screen, and surfing the web all at the same time. Now, it was maxing out with FTB alone! Something is up...

 

THEN . . . I go to play one day and all except for one chunk, was missing! Then . . . another login the whole world is now a chunk error. It was getting progressively worse each time (perhaps because something was causing the CPU to max out.

 

I just logged in again, and things seem okay except for minimal framerate issues, and that same persistent chunk error. I had the console running to try to log what is going on so I could post that for any additional info, except now the console is frozen and I can't do anything with it.  I was watching it as I walked around to gather info, and I noticed a few "Missing 5" and 10, and a few others. Then I noticed a few "Wrong location!" lines and a bunch of other red lines that I can't decipher honestly.

I searched for an answer and really cannot seem to find it. The most I've gathered was something about squid spawning like crazy? I checked that out and I've only had about 10-40 entities at any point when I was looking down at the ocean. Not sure if that'd be reliable for figuring if they were spawning like crazy though.

If anyone could possibly help me out with this situation I would LOVE you forever haha
I'm tempted to start a new world, but I'd rather know what caused this issue so I can be sure to avoid it in the future or know how to fix it.
Thank you in advance for any and all help you all can offer!



#2
Surviver365

Surviver365

    Advanced Member

  • Members
  • PipPipPip
  • 67 posts
  • Modpack:FTB Unleashed

When I have had framerate problems I normally change my RAM Maximum(MB), which is found in the options of the feed the beast launcher, low. In your situation I am not sure if this will work but it is worth a shot. Chance the RAm Maximum so it is the lost possible. I feel bad for you having that annoying chunk error and lag.



#3
ViperSRT3g

ViperSRT3g

    Advanced Member

  • Moderators
  • 212 posts
  • Location:Roanoke, VA
  • IGN:NakAttack
  • Modpack:FTB Unhinged
I've had to fix errors such as this before. This older post of mine, describes the method of finding the right region file the affected chunk is located in: http://ftbforums.org...asap/#entry1939

Once you find the region file, you are able to open it up in MCEdit, and delete the affected chunk, which you can then mark for regeneration. This will erase the corrupted chunk data, and restore it to its previous untouched form. You can then re-upload the region file to your server, and the chunk problem should be fixed.

The easiest method of solving this problem, is to delete the entire region files the affected chunks are in, thereby avoiding having to open everything in MCEdit and marking chunks for deletion.

The reason you get CPU Overloads, and Framerate issues is because both your client AND the server are trying to correct the chunk corruption, and failing miserably at it. I keep hearing that chunk corruption problems like these stem from ChickenChunks, but have not had any confirmation of the source of the problem. I do recommend upgrading from Mindcrack to FTB Ultimate as I have not had any subsequent chunk errors after the update. I can tell you that chunk errors can be caused by not having enough RAM allocated to a server, or not enough disk space for saving your world files.
  • ZL123 likes this
Vanilla Server: vanilla.vipersrt3g.net
banner-13472.png
Snapshot Server: snap.vipersrt3g.net
banner-25377.png

#4
HisServant77

HisServant77

    Newbie

  • Members
  • Pip
  • 2 posts
  • Modpack:MindCrack Pack

Thanks for the help both of you!
 

I had forgotten to mention that I had already set the allocated RAM to 2gigs, and it doesn't seem to go past 30-something % even when experiencing all those troubles. Should I aim for more than 2gb?

 

Thanks Viper, for the info too and advice on deleting/resetting the chunk. I'll have to try to work on that. Right now I moved most of my things (except machines) about 2k blocks away just in case I mess something up. Whew I had a barrel for just about every type of resource/non-machine item in the game...

 

Here's to hoping I can get it fixed. I figured I'd check out the Ultimate version after posting this, also, and think I want to aim for that. But I messed with the config files a bit more than I probably should have because now I can't even load up the Ultimate to play!

 

Let me go try to fix this chunk issue now, and I'll let everyone know if it worked for me! Thanks again






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users