Jump to content

Welcome to FTB Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

RedPower' blocks replaced by oil


  • This topic is locked This topic is locked
15 replies to this topic

#1
Sphawn

Sphawn

    Newbie

  • Members
  • Pip
  • 7 posts
  • Modpack:MindCrack Pack

Hello,

 

first of all, please excuse my mistakes, english is not my main language.

 

Here is my problem :

 

Months ago, I build a city using the following mods : Industrial Craft², Buildcraft, Redpower 2, SDK Gun Mod, Too Many Items and Single Player Commands. It was in the 1.2.3 version.

Everything works perfectly.

 

Today, I decided to continue to play this save. And I decided to install the Mindcrack pack.

But all the Redpower' blocks are replaced by oil or some weird purple square/cross.

Here are some screens :

http://www.noelshack...12-00-21-59.png

http://www.noelshack...12-00-22-38.png

http://www.noelshack...12-00-22-46.png

http://www.noelshack...12-00-23-11.png

 

I disabled all the mods, except Redpower, IC² and Buildcraft, but the problem persist.

 

So please, can someone, at least, explain to me what the problem is ?

Is my save to old or is there any way to fix this ?

 

Thank you in advance for your help :)



#2
ZER0-0

ZER0-0

    Advanced Member

  • Contributor
  • PipPipPip
  • 295 posts
  • Location:Planet Earth
  • Modpack:FTB Ultimate

The purple box seems like a texture pack bug, like you don't have the texture. Also, you should be sure you are using the newest mindcrack pack.


When in Trouble or in Doubt, Run in circles, Scream and Shout!


#3
ViperSRT3g

ViperSRT3g

    Advanced Member

  • Moderators
  • 212 posts
  • Location:Roanoke, VA
  • IGN:NakAttack
  • Modpack:FTB Unhinged

Only thing I can think of is the mods updated their block IDs. You'd have to manually edit it either with MC Edit, or do it in the game yourself. Only other thing that would worry me is the rest of the world may be slightly incorrect. But having a house made with oil like that looks kind of neat.


  • ZER0-0 likes this
Vanilla Server: vanilla.vipersrt3g.net
banner-13472.png
Snapshot Server: snap.vipersrt3g.net
banner-25377.png

#4
ZER0-0

ZER0-0

    Advanced Member

  • Contributor
  • PipPipPip
  • 295 posts
  • Location:Planet Earth
  • Modpack:FTB Ultimate

Can you upload a picture of it?


When in Trouble or in Doubt, Run in circles, Scream and Shout!


#5
Sphawn

Sphawn

    Newbie

  • Members
  • Pip
  • 7 posts
  • Modpack:MindCrack Pack

I'm pretty sure I use the pack is up-to-date, I download it 2 days ago and the launcher doesn't suggest me to update. I just try to "force-update", but the problem remain.

The purple box are more than a TP bug : the block (I assume it was marble) are missing and replaced by...potatoes.

 

A picture of what ? Of the landscape ? Its just a flat map I made myself with World Painter. There is no three, no ores...

 

I think you're right Viper : I just noticed that the emerald blocks were replaced by basalt.

But, changing all the IDs, it's seems a bit strange : it will broke every saves of every RP2 users..

 

 

EDIT : I tried to use an another pack (Direwolf20) : same problem.



#6
ZL123

ZL123

    Me.

  • Administrators
  • 2079 posts
  • Location:Not somewhere where people say a fake location to try to be funny
  • IGN:ZL123
  • Modpack:Private Pack

It's not a good idea to move a world from non-FTB or non-Vanilla to FTB.

Block IDs will be different. You could go in the config files and change the IDs of blocks manually though...

 

/MindCrack/minecraft/config


-ZL123
Hope I helped!

YT: http://youtube.com/ZL234
Twitter: https://twitter.com/ZL234


#7
Sphawn

Sphawn

    Newbie

  • Members
  • Pip
  • 7 posts
  • Modpack:MindCrack Pack

Yeah, but it will take me a long time.

I think I'm just going to install all this mods one by one and forget the modpack. Easier and faster.

 

 

Anyway, thanks a lot for your answers, it was very kind of you to help me :)



#8
Alister19

Alister19

    Advanced Member

  • Moderators
  • 38 posts
  • Modpack:Direwolf20 Pack
You tried testing on a brand new world with the pack you want?

#9
Sphawn

Sphawn

    Newbie

  • Members
  • Pip
  • 7 posts
  • Modpack:MindCrack Pack

You tried testing on a brand new world with the pack you want?

Yep. It works fine.



#10
NJM1564

NJM1564

    Newbie

  • Members
  • Pip
  • 8 posts
  • Modpack:MindCrack Pack

This won't help you but do to changes in the block ID system this probaly won't happen in the future.



#11
Alister19

Alister19

    Advanced Member

  • Moderators
  • 38 posts
  • Modpack:Direwolf20 Pack

Well then it's just simply the world trying generate blocks (and failing may I add as it's generating oil as block, it's trying to integrate mod blocks into an original vanilla world) , if it works fine in a new world, can't you make a new world with your mod pack?


Edited by Alister19, 12 February 2013 - 08:04 PM.
Missed information


#12
Sphawn

Sphawn

    Newbie

  • Members
  • Pip
  • 7 posts
  • Modpack:MindCrack Pack

Well then it's just simply the world trying generate blocks (and failing may I add as it's generating oil as block, it's trying to integrate mod blocks into an original vanilla world) , if it works fine in a new world, can't you make a new world with your mod pack?

 

Sure, I can, but I wanted to continue to build my town (which is quite big), not begin something new ;)

 

 

EDIT :

It seems that my problem is not really over yet.

As I said, I install IC², BC and RP2 one by one (using the 1.4.6 version of minecraft and the mods).

BUT, I have quite the same problem : the mods are well installed (they work, I can place the items) but they all have disappeard from my save. They are not replaced by oil, but by air.

 

Fuuuu, it seems that I have no choice : I have to change all the IDs of the items of this 3 mods.

At least, I know what to do this week-end.

 

All I have to do is changing the new ID (1.4.6) to the old ID (1.2.3) ?



#13
ZL123

ZL123

    Me.

  • Administrators
  • 2079 posts
  • Location:Not somewhere where people say a fake location to try to be funny
  • IGN:ZL123
  • Modpack:Private Pack

Have you backed up your 1.2.3 save?


-ZL123
Hope I helped!

YT: http://youtube.com/ZL234
Twitter: https://twitter.com/ZL234


#14
Sphawn

Sphawn

    Newbie

  • Members
  • Pip
  • 7 posts
  • Modpack:MindCrack Pack

Have you backed up your 1.2.3 save?

 

Yes, I've even backed up the 1.2.3' minecraft folder.



#15
ZL123

ZL123

    Me.

  • Administrators
  • 2079 posts
  • Location:Not somewhere where people say a fake location to try to be funny
  • IGN:ZL123
  • Modpack:Private Pack

Yes, I've even backed up the 1.2.3' minecraft folder.

Maybe you should just continue using that one.

Or get Forge Modloader and add the mods to a new Minecraft folder, and copy over the save, and see if Forge fixes it.

Or try to see if you can copy all the IDs over.


-ZL123
Hope I helped!

YT: http://youtube.com/ZL234
Twitter: https://twitter.com/ZL234


#16
Sphawn

Sphawn

    Newbie

  • Members
  • Pip
  • 7 posts
  • Modpack:MindCrack Pack

Maybe you should just continue using that one.

Or get Forge Modloader and add the mods to a new Minecraft folder, and copy over the save, and see if Forge fixes it.

Or try to see if you can copy all the IDs over.

 

I tried the second option, but it seems that the all the blocks from the mods disappeard ; but I can find them in my inventory and place them. So their IDs must have changed between the 1.2.3 and the 1.4.6.

So I'm going to try the 3rd option and see what happen. And if it doesn't work either, I will stay in 1.2.3.

 

Thanks for your advices.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users