←  Announcements

FTB Forums

»

Database fallout

Locked

RZR0's Photo RZR0 02 Aug 2013

Hi there, 
 
We had a couple of hours of downtime today, because our database server had failed. Some tables were damaged, but we're fairly confident that we've recovered most of the data. If you notice any problems with the forums or wiki, please post them on here. Further data recovery might be possible if needed. But the damage was mostly confined to non-critical areas of the database. 
 
~RZR0
Quote

ZL123's Photo ZL123 06 Aug 2013

Yesterday I couldn't connect to the wiki:

 

Spoiler

 

Today I can't connect to the wiki:

 

Spoiler
Quote

RZR0's Photo RZR0 06 Aug 2013

Heh, why don't people tell me this sooner :-P It is an unrelated issue, should be resolved.
Quote

felinoel's Photo felinoel 07 Aug 2013

Heh, why don't people tell me this sooner :-P It is an unrelated issue, should be resolved.

I thought it was because of that server upgrade?
Quote

RZR0's Photo RZR0 08 Aug 2013

I thought it was because of that server upgrade?

No, the webserver had a bit of a fit. All is fine now, move along :P
Quote

ZL123's Photo ZL123 16 Aug 2013

This is happening again.

It started literally about a minute ago.

 

502 Bad Gateway

_______________

nginx

Quote

Kahless61's Photo Kahless61 16 Aug 2013

I'm getting frequent 503's as well.

Quote

RZR0's Photo RZR0 16 Aug 2013

That's just because the server was just restarted after a "hardware upgrade" and the cache is being rebuilt. It takes a while and results in a high load on the server, which prevents it from serving every request in time.

On that note, if it was a problem with the database, you probably wouldn't be able to use the forums either.
Quote

Kahless61's Photo Kahless61 16 Aug 2013

I wasn't. The forums were giving me periodic 503's too.

Quote

RZR0's Photo RZR0 16 Aug 2013

I wasn't. The forums were giving me periodic 503's too.


Well, as I said, high server load :P All is fine now, load has dropped back under 30%.
Quote

ZL123's Photo ZL123 30 Aug 2013

What happened just now? The forums and wiki have been giving me 502s and 503s for like three hours.

Quote

ostPavel's Photo ostPavel 30 Aug 2013

 

[12:53:50] <@ostPavel> RZR0: what was the reason of the downtime?

[13:10:35] <@RZR0> ostPavel: Webserver was acting up
Quote
Locked