Jump to content

Welcome to FTB Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

image uploading issues

twilight forest wiki issue image file upload

7 replies to this topic

#1
digitallyApocalyptic

digitallyApocalyptic

    Advanced Member

  • Administrators
  • 262 posts
  • IGN:GameStopper
  • Modpack:FTB Ultimate

So right now I'm working on the Twilight Forest section, as I have been for a few days now. Image fixes is the task of the moment, and I've uploaded quite a few images, but for some reason, I'm getting stuck on images that have visual artifacts from their innate enchantments, such as the Fiery and Steeleaf gear.

 

I'm fairly certain that this is due to previous versions having visual artifacts from enchantments, but I'm not sure how to work around this to remove those visual artifacts as I've managed to create image files that don't have these artifacts. Whenever I upload the file, it reverts back to the older version for some reason as it probably thinks that it's a duplicate due to it being essentially a palette swap. Might be a bug with uploading new versions of images, however. I'm not sure.

 

I'm not sure how to fix this, although I'm pretty sure that this is something that should be fixed for most items. With stuff that can be spawned in with NEI and still have its enchants, maybe it should retain its enchantment artifacts, but I'm inclined to say that no images should have enchantment artifacts as that is the way that they appear in the items.png file of the mod folder.

 

Thoughts/suggestions/fixes? I'm slightly at a loss here. In the meanwhile, I guess it's time to do some actual writing ._.

 

but not before I derp around on my Twilight Forest survival world for an hour or two


My username is digitallyApocalyptic. I contribute where I can on the wiki and I've previously built pretty much the entirety of Category:Twilight Forest. I play FTB Ultimate, some games on Steam, and I follow MS Paint Adventures.


#2
ZL123

ZL123

    Me.

  • Administrators
  • 2079 posts
  • Location:Not somewhere where people say a fake location to try to be funny
  • IGN:ZL123
  • Modpack:Private Pack

Hey, I've been around the TF section too, recently. I did notice that the items had enchantments on their pictures. When the items are crafted, they do have enchantments automatically, but I think it's possible to get them without the enchantment.

Also, does combining an Enchanted Book with a piece of originally-already-enchanted Twilight Armor work? I assume it does.

 

Not about the topic of the Twilight Forest mod, but on the topic of image bugs, I tried to update the picture of the Logic Matrix Programmer. It appears like a Cake Block to me in the Crafting Grid, but in the Nav template, it looked normal. RZR0 uploaded the original Logic Matrix Programmer file, and it looked like a Cake Block! Then I uploaded my version, which, I assure you, was an actual Logic Matrix Programmer picture. And it reverted back into a cake.

The cake is a lie!

 

?!


-ZL123
Hope I helped!

YT: http://youtube.com/ZL234
Twitter: https://twitter.com/ZL234


#3
Artsja

Artsja

    Advanced Member

  • Administrators
  • 94 posts
  • Location:Austria
  • Modpack:FTB Ultimate

I believe sometimes images just take a while to update in the cache. During that time it will show the old picture in place of the new one you just uploaded. It's not a bug and it'll eventually update to the correct picture, so there's no need to try and upload the correct picture again. Just takes a few minutes.

 

As for whether to keep the enchantment glow on Grid images or not, I thought it was okay to keep them to indicate that the item is enchanted by default, but I also don't mind if the original picture is used.



#4
digitallyApocalyptic

digitallyApocalyptic

    Advanced Member

  • Administrators
  • 262 posts
  • IGN:GameStopper
  • Modpack:FTB Ultimate

I would assume that combining an enchanted book with a piece of innately-enchanted TF armor would work, as there's no reason why it wouldn't, but I haven't done any formal testing on that. If you do some testing on that and you come up with strange or differing results, feel free to edit the respective articles :) I may also test that eventually, but stuff like that is a bit low-priority at the moment due to the sheer quantity of pages that either don't exist or have little to no information.

 

I think that I'm going to start replacing images with the image sans enchantment glow, as that is technically how the item appears in the items.png, but I will definitely add a note that says that the item has X enchantment (e.g. fire aspect for the Fiery Sword) and will have this enchantment even if spawned in with NEI.

 

Edit: I uploaded some images without enchantment glow last night, and the cache still hasn't updated or doesn't appear to have updated. I'm going to upload an image for Grid_Fiery_Boots.png, wait a while, see if that changes, and if it doesn't, I suppose I'll have to look into this further. At this point, it hopefully shouldn't be a permissions issue as my name on the list of users has administrator in parentheses next to it; at one point I thought it might be a permissions issue since the wiki wasn't recognizing me as sysopped due to my not having logged out and back in again, but this should no longer be the case.


My username is digitallyApocalyptic. I contribute where I can on the wiki and I've previously built pretty much the entirety of Category:Twilight Forest. I play FTB Ultimate, some games on Steam, and I follow MS Paint Adventures.


#5
gerbalb

gerbalb

    Member

  • Administrators
  • 17 posts
  • Modpack:MindCrack Pack
In order to keep the server from bursting into flames RZR0 has implemented some fairly long cache times. In most cases you can override the caching by refreshing the page twice in quick succession.

#6
Artsja

Artsja

    Advanced Member

  • Administrators
  • 94 posts
  • Location:Austria
  • Modpack:FTB Ultimate

To add to what gerbalb said, Ctrl + F5 updates your cache. Alternatively, try purging.

The pictures you uploaded look fine to me, unless I'm missing something here.



#7
digitallyApocalyptic

digitallyApocalyptic

    Advanced Member

  • Administrators
  • 262 posts
  • IGN:GameStopper
  • Modpack:FTB Ultimate

Alright, the double refresh seems to be fixing the problem. Thanks everyone for your help and sorry about the confusion >_>

 

Re: the picture that Artsja posted: for whatever inane reason, my computer was seeing that the newest image still had the enchantment glow and the ones in between had no enchantment glow. Anyways, shouldn't be a problem anymore.


My username is digitallyApocalyptic. I contribute where I can on the wiki and I've previously built pretty much the entirety of Category:Twilight Forest. I play FTB Ultimate, some games on Steam, and I follow MS Paint Adventures.


#8
ZL123

ZL123

    Me.

  • Administrators
  • 2079 posts
  • Location:Not somewhere where people say a fake location to try to be funny
  • IGN:ZL123
  • Modpack:Private Pack

I would assume that combining an enchanted book with a piece of innately-enchanted TF armor would work, as there's no reason why it wouldn't, but I haven't done any formal testing on that. If you do some testing on that and you come up with strange or differing results, feel free to edit the respective articles :) I may also test that eventually, but stuff like that is a bit low-priority at the moment due to the sheer quantity of pages that either don't exist or have little to no information.

 

I think that I'm going to start replacing images with the image sans enchantment glow, as that is technically how the item appears in the items.png, but I will definitely add a note that says that the item has X enchantment (e.g. fire aspect for the Fiery Sword) and will have this enchantment even if spawned in with NEI.

 

Edit: I uploaded some images without enchantment glow last night, and the cache still hasn't updated or doesn't appear to have updated. I'm going to upload an image for Grid_Fiery_Boots.png, wait a while, see if that changes, and if it doesn't, I suppose I'll have to look into this further. At this point, it hopefully shouldn't be a permissions issue as my name on the list of users has administrator in parentheses next to it; at one point I thought it might be a permissions issue since the wiki wasn't recognizing me as sysopped due to my not having logged out and back in again, but this should no longer be the case.

Well, there's no Enchanted Book in FTB Beta A because it's in 1.4.2. When I try to create/load up a MindCrack World, my game crashes. Probably because of my not-so-good computer, but I don't need a fix, thanks. :P


-ZL123
Hope I helped!

YT: http://youtube.com/ZL234
Twitter: https://twitter.com/ZL234




Reply to this topic



  



Also tagged with one or more of these keywords: twilight forest, wiki, issue, image, file, upload

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users